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INTRODUCTION

This program is in Visual Basic for Applications and requires ArcGIS 8.1. Associate the
form with a UIButtonControl (see below for example). It allows the calculation of
Area, Perimeter and Centroids for polygon layers in either the units of the shapefile
source (native) projection or the projection of the current DataFrame in ArcGIS; both
of which are displayed for your choice. You can use it to calculate all three geometric
properties or any one or other combination therein by choosing only the check-boxes
under "Calculate" that you desire. You can delete these fields afterwards or only the
selected ones you don't want to retain in the same way. By default the program will
replace any fields called AREA2, PERIM2, X-CENTER2 or Y-CENTER2. If you want
fields updated that are already called "AREA", "PERIMITER"...etc. then de-select the
"Create second set.." button:

Calculate Polygon Geometry {c) Dr. M.Sawada 2002

CALCLULATE
v area

— For the Laver canalbers, choose one of the Following

" Calculate geometry using in native map projection which is:

Canada_galbers_Equal_area_Conic V' Perimiter

¥ Centroids

% Calculate geometry in Data Frame's current Projection which is:

Creabe second Go
Canada_| ambert_Conformal _Conic [~ iset "AREAZ",
"PERIMZ",... about
Delete Fields Close

The output is appended to the layer's table and looks like this:

ER Attributes of canalbers o ] 1
AREA PERIM #-CENTER Y-CENTER -
3 1517529511760 15903525, 322680 1573257 794154 1724751.1937
3418045416470 BE54 2855, 539651 -260337 122459 31932540700
54909444364.8 A723744. 384343 2458532 430803 11739719367
B51990142635 J575691.934094 -B36419.220742 16130796345
BEE263918397 JE8E7 25485825 1151015183602 1815982 5480
394494864210 16089501 403956 2297018.057093 20304606144
944615623763 15848692 329273 -1761264.0681 06 1983063, 767
7ZE09706414.7 1930202104084 2215500391187 121851595598
5717096109.52 866940 684667 2442398.965709 1305027 471C
| 451248324033 4158008168577 -1818690.921470 | 59064, ?E?ILI
4 3
Fecord: LILII 1 _Dlﬂl Shio: W Selected | Fiecords [0 out of 12 Selected.) [Options
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Resources

NOTES:

1. The calculated fields may show all zeros if the layer's table is open when
the calculation is executed - don't worry, it just hasn't refreshed, so close
it and reopen the table and the values will be there.

2. For very large numbers (say the area of the province of Quebec in m?),
field values may be rounded (no decimal places will be maintained) to the
nearest 10" automatically by ArcGIS - this is a bug with ArcGIS. ArcGIS's
double fields will only allow 12 full numbers (e.g., 111111111111) before
the decimal place. With a number that large, no decimal places, if there
are any, will be retained by the field, and larger integers will be rounded to
the nearest 10" (e.g., 1111111111115 becomes 1111111111120 etc..).
You may actually see numbers that large with a couple decimal places but
as soon as the table is operated on in some fashion the values will be
rounded. Most calculations of area or perimeter won't be accurate to that
level of precision anyway but if you are working in cm it could be a
problem or for some custom coordinate systems with excessively large
false eastings or northings. ArcView 3.2 did not have this behavior.

3. This program may not work on ArcInfo Coverages - it may crash your
session with ArcGIS if run on coverages.

Additional Resources on GIS

You may find some of my course websites useful for
introductory material on GIS:

GEG 2320: Introduction to Geographic Information

Systems
http.//www.uottawa.ca/academic/arts/qgeographie/|
pcweb/web2320/

Greens Creek

*GEG2302: Introduction to Cartography
http://www.uottawa.ca/academic/arts/qgeographie/locweb/geq2302/

*GEG4120: GIS and Numerical Spatial Analysis
http:.//www.uottawa.ca/academic/arts/qgeographie/locweb/web4120/

GEG6102: Advanced Geomatics
http.//www.uottawa.ca/academic/arts/qgeographie/locweb/web6102/

*Requires Macromedia Flash plugin for browser.

ADDING CusTOM OONTROLS REFERENGCED TO VBA MACROS TO
THE ARCGIS INTERFACE

NOTE: This document shows how to load a form called
frmLayerInfo. Wherever you see frmLayerInfo you need
to substitute frmAreaPerimCentroid.

Many programs written in Visual Basic for Applications will come in the form
of VB Forms (the form you interact with by clicking or entering information).
These forms can be associated with buttons on the the ArcGIS GUI (Graphical
User Interface). By associating a VB Form containing some custom program
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with a new button, you will have access to its custom functionality in any
ArcGIS session. Everytime you open ArcGIS you are opening the
"Normal.mxt" document. This document is called a 'template’ and contains
the information necessary for ArcGIS to reconstruct the standard user
environment (all the buttons and menu items you see evertime you start the
program).

% Untitled - ArcMap - ArcInfo =10l x|

File Edit View Insert Selection Tools ‘Window Help

| Georeferencing ™ | La.'r'Efil j ﬂj =i .|/|- J 30 An
| DEES| 4 B@X |0 || o 2| &

Editor = | 3 |! - |Task: ICreate Mew Feature j | Tarqet:l
I EEEEEET R YR L

:ﬂg -
cu
i
izl
3 -
i [anm| a4 ]
| orawing ~ R (| O~ A v 1< |[aia =0 - B 2

[2345,79 757.01 Unknown Un 7

It is in this "Normal" template that you will import a custom VB Form and
associate that form with a custom button on the GUI. Once saved, it will be
available to you each time you start ArcGIS.

Step 1 Step 1: Finding the Normal.mxt

The Normal.mxt is found within the Visual Basic for Applications (VBA) Editor:

1. Click on Tools->Macros->Visual Basic Editor in the menubar:

p Macros, .. alk+Fa

ben visual Basic Editor  Alt+FLL

2. Next you will see the visual basic editor
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£ Microsoft Yisual Basic - Normal.mxt O] x|

JEiIe Edit Mg Insert Formak Debug Run Tools Add-Ins indow Help |

l.ﬁ|ﬁ’%"ﬂ"|@

B R Normal {Mormal.mxt)
- Project

On the left side is the Project Explorer and in here you will see the
Normal.mxt template as the first item.

3. Click on the "+" sign to expand it, and then expand the folder called
"ArcMap Objects".

<@ Microsoft Yisual Basic - Normal.mxt =10l x|
JFiIe Edit Wiew Insert Format Debug Run Tools Add-Ins Window Help |

@3- H|3:E!ﬁ|““| n ek MEEE 0 2 =2

Project - Mormal

af==Jif= |

= gﬁ Mormal {(Mormal.mxt)

: EI ﬁ ArcMap Objects
e ¥ ThisDocument

: l -7 Modules

- gﬁ Project

4. We will come back to this later. The item under "ArcMap Objects" called
"ThisDocument" will eventually contain two lines of code that will load our
custom user form by clicking on a button within the ArcGIS GUI.

Step 2
Step 2: Importing the custom form into the
Normal.mxt document template

We now need to load the custom userform called frmLayerInfo into the
"Normal.mxt" document:

1. Click on File->Import File in the VB Editor menubar:
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£ Microsoft Yisual Basic - Normal.mxt O] x|

(—

File Edit “iew Insert Format Cebug Run Tools add-Ins Window Help

H Save Mormal.maxt Chrl+5

» 1 mbd HEFE 2@

Impatt File., .. Che|+0
Export File. .. Zkr+E

— 1 — h=l—

Remove ThisDacument, ..

&5 Print... Ctrl+P

[ Close and Return to ArcMap  AlL+0

2. Navigate to where you have saved the files frmLayerInfo.frm and
frmLayerInfo.frx:

Import File
Look in: I a march13

RlirrLaverinfo fim)

File name:  {frml_averl nfo.frm Open

Files of type: ~ [w/B Files [* fm.* bas.* ) 4 Cancel

Pl

Help

3. If you look now at your Project Explorer you will see a new folder called
"Forms" underneath the folder called "ArcMap Objects". Click on the "+"
sign and you will see the frmLayerInfo form item within the folder:
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£ Microsoft Yisual Basic - Normal.mxt O] x|
JEiIe Edit Miew Insert Formak Debug Run Tools Add-Ins dindow Help

[@E-8 ¢ BEadk ooy nad¥EE2 @ 2 =2
]

Project - Normal

oE|a |

=& Normal (Normal.mxt)
EI@ arcMap Ohjecks

- i@ ThisDocumert
=145 Forms
O =l I
[ (77 Modules
E]---ﬁ Project

You have now loaded the custom userform called frmLayerInfo into the
Normal. mxt document template.

4. Now save the normal template by clicking on File->Save Normal.mxt in
the menubar.

<@ Microsoft Yisual Basic - Normal.mxt =10l x|

(—

File Edit “iew Insert Format Debug Run Tools Add-Ins Window Help |
;aw Marrnal, rok T | 2 EE e | (2]

Impart File, .. kel
Expatt File., .. Ckrl+E

— 1 — hl—

Remove frmLayerInfao., .

&5 Print...

Close and Return ko ArcMap
N 3 i [aTn 18| (=2
+-&% Project

Step 3 Step 3: Creating a custom UIControlButton
in ArcGIS GUI

Now that we have the custom form called frmLayerInfo within the ArcGIS
Normal.mxt document template we next need to put a button on the button
bar in ArcGIS that will load the form when we want to use its functionality
within the GIS program.

1. Return to the ArcGIS program
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@ _Untitled - ArcMap - ArcInfo - O] x|

File Edit Wiew Insert Selection Tools wWindow Help

| Geareferencing ¥ | Lﬂ}'ETZI j ﬂj - S JSD Aan
| DERE| 4 =@X |0 || 2|2 &| w2

] Editor | ~ |! il | Tasks ICreate Mew Feature j | Targek: I—
_ﬂﬂ@|@@@mml1002vl|@‘ﬂJ@@:: Ry L

ﬂ%_l e
E.lr
=
I
o -
Displa_l,l P ﬁ|3|e4| |ﬂ
JDrawingv §@||:|vAvﬂ||mia| =l =] B 2z

[B11.69 &70.13 Unknown Unit 7

2. Right-click on any grey area of the Menubar and you will see the
Customize Menu Appear. Choose the Customize... item at the bottom.

IT Main Menu

IT Skandard

IT Tools

IT Diramy

|v Edior

IT Spatial Analwst
Effects

IT zeoreferencing

IT 3D Analysk

IT Layauk
araphics
aenstatistical Analyst
Dirmensianing
Data Frame Tools
LIkiliey Metwork Analyst
Mersioning

Edit Cache

Customize. ..

Yiew Source

3. Now the Customize Dialog box is showing. Click on the Commands Tab at
the top of the Customize dialog box and scroll down until you find the item
called "UIControls":
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Customize el

Toolbars  Commands | Dptinnsl

Categories: Commands:

b emuiz ;I

Mew bernu
Page Layout
Fan/Zoom
Report Object
Selection
Spatial Analyst
Surface

Text
TIM
Toal:

New UlContpl.. |
/

Sl ima?,ma_mgt =] Keyboard.. | Add from file...l Close |

4. Click on the button called NewUIControl...

5. Now the New UIControl dialogbox comes up and you want to create a new
UIButtonControl (a button that eventually you can press and when you
press it will load the user form called frmLayerInfo)

[elete U Eontmal | [Nezcrptian |

I Cantral Type

% LIButtanControl " UIEditB oxControl

" UIT oolCantral " UlComboB axCaortral

Create I Create and E dit Cancel

6. The Customize dialog box will now show a new Normal.UIButtonControll
in the Commands: window pane on the left hand side:

Dr. M.Sawada Page 8 of 12



Step 4

README: Geometry VBA Macro Installation

Customize

Toolbars  Commands | Elptinnsl

Categaries:

M eruz ﬂ

MHew Menu
Fage Layout
Pan/goom
Repart Object
Selection
Spatial Analyst
Surface

Teut
TIM
Toolz

Commands:

L M armal. LB uttanCantral 1

2l xi

Ultility Network Analyst hd
Mew UIContal... I Delete UIContal | Dezcription |
Sawe ir | Mormal. st j Keyboard... | &dd from file. .. | Cloze |

This Normal.UIButtonControll references the "Normal.mxt" document, hence
the prefix "Normal" in front of the UIButtonControl. This button will now be
associated with the user form so that when it is clicked it will load the
userform and provide us with the necessary functionality to run the custom
program.

Step 4: Associating the new
UIButtonControl with the frmLayerInfo
within the Normal.mxt template

This is the semi-final step to giving a custom macro universal functionality
within ArcGIS.

1. Double click on the item Normal.UIButtonControll

Dr. M.Sawada
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Customize

Toolbars  Commands | Elptinnsl

Categaries:

Commands:

M eruz

MHew Menu
Fage Layout
Pan/goom
Repart Object
Selection
Spatial Analyst
Surface

Teut
TIM
Toolz

.L!tilit_ll,l N.etwu:urk Analyzt

Mew UIContmal... I

=

Delete U Cantral |

L M armal. LB uttanCantral 1

Dezcription |

2l xi

-

Save in; I I arrnal. ot

K.epboard...

| add from fie... |

Cloze |

2. This will "Jump" you over to the Visual Basic Editor and the ThisDocument
item under the ArcMap Objects folder within the Normal.mxt template.
Now type in the following:

£ Microsoft ¥isual Basic - Normal.mxt - [ThisDocument (Code)]

Jm File Edit Wiew Insert Format Debug Bun Tools Add-Ins Window Help

Jm‘: EI|J£ ham

ﬂﬁ'| lﬁ|ﬁ’%"ﬂ‘|@ 2 E 2
II.IIButtnnCnn‘truH ICIit:k j

IR

=- @ Mormal {Mormal.mxt)
=8 @ ArcMap Objects
-G ThisDocumertt
EI @ Forrs
¢ [ frmLayerInfa
|:| Modules

Load frmwLayerInfo

End Sub

Ea---@ Project == «||

'loads form

frmLayer Info.3how 'shows form

Private Zuh UIButtonControll Clicki)

3. Now click the File->Save Normal.mxt in the menubar and you are almost

finished.
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Step 5

£@ Microsoft ¥isual Basic - Normal.mxt - [ThisDocument (Eudef'}z: O] x|
Jm File Edit “iew Insert Format Cebug Run Tools Add-Ins Window Help = |ﬁ’|£|
J - & Mormal, mxt ey o om Y | B8 & o | (2] » J =¥
Proj Impatt File. .. kM lntroi j ICIit:k j
.
—  ExportFik.. S — UIButtonControll Click() o
=-8 Remave ThisDacument, .. oad frmLayerInfo 'loads form
[ rmLayerInfo.3how 'shows form
&5 print... ctrl+p  [ub
|
Close and Return to ArcMap  Alk+0
T TS =
Eﬂ@ PI"DjEEt = E 4 I I »

Step 5: Placing the new UIButtonControl
onto the ArcGIS Interface

This is an easy step. It involves dragging the new button onto one of the
button bars of ArcGIS.

1. Right-click on any grey area of the Menubar and you will see the
Customize Menu Appear. Choose the Customize... item at the bottom.

|7 Main Menu

|7 Skandard

I7 Toals

|T Drraw

v Editor

|7 Spatial snalyst
Effects

I7 Geareferencing

|T 30 Analysk

|7 Laviouk
Graphics
Geostatistical Analyst
Dirmensioning
Data Frame Tools
Lkility Metwork snalesk
Yersioning

Edit Cache

Customize. ..

Wiew source
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2. Goback to the Commands Tab and scroll down to the UIControls and you
will see your Normal.UIButtonControll1

Customize il EI

Toolbars Commands | Elptin:nnsl

Categaries: Commands:

Page Layout ﬂ L1 Marmal UIB uttanCantrall
Fan/Zoom

Report Object
Selection
Spatial Analyst
Surface

Text

TIM

Toal:

Litility Mebwork, Analpst
Yerzioning
Wiew -

Mew UlContmal... I [elete U Eontrol | [Nescriptiarn |

Save in: INDrmaI.m:-:t j Feyboard... | Add fram file. . | Cloze I

4. Click and drag this button onto one of the button bars within ArcGIS.
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